Configuration requise

Vous trouverez ci-dessous les informations techniques liées aux versions stables de SPIP.

Un serveur http configuré pour fonctionner avec PHP

  • Serveur Apache ou compatible (versions supérieures à la 1.2x)
  • Serveur Nginx

Prochaine version

Pas de version prévue pour le futur actuellement.

Versions maintenues

SPIP 4.0

Requis

  • Compatibilité PHP: 7.3 - 8.0
  • Extensions PHP: xml, gd2

Suggestions

  • Base de données
    • SQLite : 3
    • MySQL : 5.0 - 5.7
  • Traitement d'images
    • NetPBM
    • Imagick/convert
    • Freetype

Fournit

  • jquery v3.6.0

Besoin système minimum

  • Espace disque (hors base de données) : 150 Mo
  • Mémoire RAM : 128 Mo

SPIP 3.2

Requis

  • Compatibilité PHP: 5.4 - 7.4
  • Extensions PHP: xml, gd2

Suggestions

  • Base de données
    • SQLite : 3
    • MySQL : 5.0 - 5.7
  • Traitement d'images
    • NetPBM
    • Imagick/convert
    • Freetype

Fournit

  • jquery v3.2, jquery-ui v1.12

Besoin système minimum

  • Espace disque (hors base de données) : 150 Mo
  • Mémoire RAM : 128 Mo

Fin de vie

SPIP 3.1

Requis

  • Compatibilité PHP: 5.1 - 7.1
  • Extensions PHP: xml, gd2

Suggestions

  • Base de données
    • SQLite : 3
    • MySQL : 5.0 - 5.7
  • Traitement d'images
    • NetPBM
    • Imagick/convert
    • Freetype

Fournit

  • jquery v1.11.3, jquery-ui v1.11.4

Besoin système minimum

  • Espace disque (hors base de données) : 150 Mo
  • Mémoire RAM : 128 Mo

SPIP 3.0

Requis

  • Compatibilité PHP: 5.1 - 5.6

Suggestions

  • Base de données
    • SQLite : 3
    • MySQL : 5.0 - 5.7
  • Traitement d'images
    • NetPBM
    • Imagick/convert
    • Freetype

Fournit

  • jquery v1.7.2

Besoin système minimum

  • Espace disque (hors base de données) : 150 Mo
  • Mémoire RAM : 128 Mo

Auteur Teddy Publié le : Mis à jour : 14/08/21

Traductions : English, français, Nederlands