SPIP

[ar] [ast] [bg] [br] [ca] [co] [cpf] [cs] [da] [de] [en] [eo] [es] [eu] [fa] [fon] [fr] [gl] [id] [it] [ja] [lb] [nl] [oc] [pl] [pt] [ro] [ru] [sk] [sv] [tr] [uk] [vi] [zh] Espace de traduction

Télécharger

Використання spip_loader

Novembre 2015

Toutes les versions de cet article :

«spip_loader» - це скрипт, який дозволяє вам встановити SPIP чи оновити його версію автоматично, не передаючи всі файли за допомогою FTP.


Поточна версія spip_loader: 2.5.6

Використання spip_loader для автоматичної інсталяції SPIP

  1. Завантажте скрипт http://www.spip.net/spip-dev/INSTAL....
  2. Помістіть через FTP цей файл в каталозі, де ви хочете встановити SPIP (як правило, в кореневому каталозі вашого сервера).
  3. Викличте скрипт з браузера http://www.my.domain/spip_loader.php
  4. Скрипт перевіряє сумісність вашого хостингу, а потім вказує версію SPIP, яку буде встановлювати чи оновлювати.
  5. Розпочніть автоматичне встановлення.

Після установки SPIP ви можете залишити сценарій spip_loader.php (починаючи з версії 2.1) на своєму сервері. Тільки авторизовані адміністратори можуть отримати до нього доступ. Перевагою є те, що за потреби оновити SPIP дуже легко.

Використання spip_loader для виконання оновлення

Щоб оновити SPIP, виконайте ту ж процедуру:

  1. Помістіть скрипт на сервер, якщо він ще не там.
  2. Викличте сценарій з браузера http://www.my.domain/spip_loader.php.
  3. Розпочніть автоматичне встановлення.

Перед викликом скрипта треба спочатку увійти SPIP.

За замовчуванням, тільки автор # 1 (тобто веб-майстер сайту) може виконувати оновлення.
Якщо ви хочете додати інших авторів, відредагуйте рядок скрипту:
define('_SPIP_LOADER_UPDATE_AUTEURS', '1');

Увага:
Якщо ви хочете використовувати spip_loader для оновлення SPIP у версії 2.1, прочитайте наступний абзац, щоб змінити версію.

Встановлення іншої версії

За замовчуванням, скрипт виконує установку і оновлення до останньої стабільної версії SPIP.

Якщо ж ви хочете встановити чи оновити іншою версією, змініть рядок у файлі
define('_CHEMIN_FICHIER_ZIP', 'spip/stable/spip-3.0.zip');
наприклад, замініть
'spip/stable/spip-3.0.zip'
на:
'spip/stable/spip-2.1.zip' .

Що робити у разі відмови?

Spip_loader може не завантажувати файли. Загалом, це викликано проблемами на сервері. У цьому випадку встановюйте SPIP

  • або шляхом передачі файлів вручну через FTP
  • або за допомогою Subversion (для досвідчених користувачів)

Voir le squelette de cette page Site réalisé avec SPIP | Espace de traduction | Espace privé